[FYI] 自行編譯出Hadoop 0.20.1+ Eclipse Plugin

|
打從hadoop 0.20.0 以前,我們用Eclipse 開發Hadoop程式,搭配放在hadoop_home/contrib/eclipse-plugin目錄下的 hadoop-eclipse-plugin.jar 來用是事半功倍,如虎添翼。

不過問題是,該plugin 並沒有說明適用於哪個eclipse 版本,因此某些版本的eclipse用了該套件會有某些功能無法運作的情況(如:run on hadoop 按鈕無法使用)。更何況,hadoop 0.20.1 以後,hadoop_home/contrib/目錄下已經沒有 eclipse-plugin 可以用了,開發者的目的應該就是要各位自己編譯產生吧?

但自行編譯產生出eclipse plugin 需要一些KnowHow,偷懶的方法可以1. 用hadoop 0.20.0 的plugin 2. 用別人已經編譯好放在網路上的plugin 。   不過問題回過頭來,eclipse 版本不正確還是會導致某些功能無法使用。

若你已經準備好要自己編譯 hadoop eclipse plugin ,可以看這篇
http://trac.3du.me/cloud/wiki/waue/2010/0211